Desktop start-up command parameter issue

Post any technical problems or questions you have while using or configuring Dexpot.
Bug-Tracker
stephano
Posts: 1
Joined: 28.02.2017 09:41:06

Desktop start-up command parameter issue

Postby stephano » 28.02.2017 10:12:24

I tried searching for this issue, but couldn't find anything, sorry if I missed it.

I created a Desktop start-up event to start Chrome with a specific profile, using the --profile-directory="profile 2" parameter for Chrome. This however doesn't work, because apparently Dexpot removes the double quotes from the profile name, resulting in Chrome opening with the "profile" profile, which doesn't exist.

The exact command I save looks like this:
"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --profile-directory="Profile 2"

Here is the debug log output, where you can clearly see the double quotes aren't saved/executed properly:

09:36:45> Lösche Hotkeys.
09:36:45> Registriere Hotkeys.
09:36:48> Lade Sprache für frmKonfig.
09:37:03> Switch by: Main menu
09:37:03> >>> Desktopwechsel von 1 nach 3 >>>
09:37:03> Aktives Fenster: Configure Desktops - Dexpot (855704)
09:37:03> --- Taskbarbuttons auf Desktop 1
09:37:03> Aktualisiere Desktop.
09:37:03> Verstecke Fenster (move) 66614: qBittorrent v3.3.10, Qt5QWindowIcon, qbittorrent.exe
09:37:03> Verstecke Fenster 1182358: UltraEdit 64-bit, Afx:0000000140000000:8:0000000000010003:0000000000000000:0000000000020CAB, uedit64.exe
09:37:03> Verstecke Fenster (move) 330190: C:\Users\steph\AppData\Roaming\Dexpot, CabinetWClass, explorer.exe
09:37:03> Verstecke Fenster 855704: Configure Desktops - Dexpot, ThunderRT6FormDC, dexpot.exe
09:37:03> --- Stelle 0 Taskbarbuttons wieder her...
09:37:03> ---
09:37:03> Zeige Fenster (move) 262270: , WindowsForms10.Window.8.app.0.3ce0bb8, Emc.Captiva.WebToolkitHost.exe
09:37:03> Not tokenized.
09:37:03> Schautostarte mit Vista-Methode: C:\Program Files (x86)\Google\Chrome\Application\chrome.exe | --profile-directory="Profile 2"
09:37:03> Desktopwechsel abgeschlossen.
09:37:03> Plugin: autodex: create auto skip 0 "DESKTOP-NF04N69\Stephan" "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --profile-directory="Profile 2"
09:37:03> Plugin: autodex: Task count: 4
09:37:03> Plugin: autodex: Task name: 2
09:37:03> Plugin: autodex: Path: C:\Program Files (x86)\Dexpot\autodex.exe
09:37:03> Plugin: autodex: Arguments: run "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --profile-directory=Profile 2
09:37:03> Plugin: autodex: Task registered
09:37:03> Plugin: autodex: run "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --profile-directory=Profile 2
09:37:03> Plugin: autodex: Running as PID 6124
09:37:08> Lade Sprache für frmEinstellungen.
09:37:08> Lade Sprache für frmEinstellungen.
09:37:12> <<< Logdatei deaktiviert.

Is there perhaps a work around for this?

Keyser Söze
Posts: 4
Joined: 22.02.2017 00:42:59

Re: Desktop start-up command parameter issue

Postby Keyser Söze » 21.03.2017 21:34:49

I suggest you try the following:
"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe --profile-directory="Profile 2""

the whole command is enclosed within strings, including the startup parameters (profile 2). so yes, there are 2 " at the end indeed.

another option would be renaming the profile to profile2:
"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe --profile-directory=Profile2"

then you get rid of the quotes for its name.


Return to “Support”

Who is online

Users browsing this forum: YandexBot [Bot] and 2 guests