Desktop switching is extremely slow

Here you may post suggestions for improving and extending Dexpot.
SuperElitist
Posts: 1
Joined: 01.09.2015 22:24:34

Desktop switching is extremely slow

Postby SuperElitist » 01.09.2015 22:50:04

I'm running Win8.1 64-bit on an i7-4770, 16GB, with (4) Asus VE278H monitors (1920x1080 each), two each on a GeForce GT 730 and 640 respectively. Storage is a 120GB Kingston SSDNow V300. This is a very respectable computer.

However, Dexcube is extremely laggy - anywhere from ~500ms to upwards of several seconds. To be clear, it is not the animation that is slow. Rather, when I hit the keys to switch, there is a delay in which nothing happens at all, and then it smoothly animates. I used to run Compiz (in cube mode) on Ubuntu, and am unused to any lag at all in desktop switching. If I was seeing 50-100ms lags, I might chalk it up to Dexpot being slow or poorly written, but this is a LOT of delay. I have to assume that if everyone was seeing this sort of lag, it would be a big deal, so I'm posting this in the support forum in hopes of resolving it.

Things I've tried:
* Settings -> Plugins and Extras -> Turning off all plugins
* Settings -> Plugins and Extras -> Dexcube -> Configure -> Multithreading, Shadow, Transparency (in any combination)
* General -> Start -> Process Priority
* General -> Start -> Run as Administrator
* I have also tried closing all open programs.

I'm still seeing unusably long delays before switching.

Anyone have any ideas?

User avatar
Sebastian
Developer
Posts: 5165
Joined: 04.03.2003 14:47:54
Location: Dinslaken
Contact:

Re: Desktop switching is extremely slow

Postby Sebastian » 11.11.2015 10:05:15

:dex:,

this is Dexcube freeing up memory quickly after using it. I consider your post a feature suggestion for a corresponding option.
Best regards (wave)
Sebastian Brands, Dexpot GbR

Gast

Re: Desktop switching is extremely slow

Postby Gast » 25.04.2018 20:42:46

I have de same problem. With Dexcube there is a delay, even if i se the times to zero. When i don't use Dexcube, there is no delay. How can i solve this problem? Because the animation are good, but with this delay it is useless, sadly.


Return to “Feature requests”

Who is online

Users browsing this forum: No registered users and 5 guests