Windows 7/Dexpot problem with different backgrounds for each Desktop

Post any technical problems or questions you have while using or configuring Dexpot.
Bug-Tracker
aboutblank
Posts: 2
Joined: 18.08.2014 10:49:26

Windows 7/Dexpot problem with different backgrounds for each Desktop

Postby aboutblank » 08.02.2020 03:15:36

I've scoured this forum for a solution to a problem I have been having on two different Windows 7 PC's, my desktop and my Dell Inspiron laptop. Each is running Dexpot 1.6.14, Build 2439, and is configured similarly. Each has DexControl, Dexcube, SevenDex, and Taskbar Pager checked under Settings, and each has four desktops. Each desktop has its own wallpaper assigned, a different JPG file for each of the four desktops. (The pictures on each PC are different.)

The problem that I recently (February 2020) encountered on both computers is that switching to a different Desktop often resulted in the background for that Desktop being displayed incorrectly, i.e., the image being displayed was not the one in the Dexpot "Configure Desktops" - "Background" settings. Sometimes the background on Desktop 2 (or 3 or 4) was the same as for the background assigned under Windows for Desktop 1, sometimes the background would be one for another desktop. The problem did not seem consistent, except for the fact that the wrong background was displaying.

I finally figured out a workaround: I resaved each image to a .BMP file, made from the .JPG file that I had been using. Additionally, I went into Windows Personalization settings, and selected the proper BMP file for the background for Desktop 1, then selected that exact same image in Dexpot for the background for Desktop 1, instead of the transcoded image that had been selected previously. I then used Dexpot's "Configure Desktops" - "Background" settings to change the background image on each additional Desktop, i.e., on Desktops 2 and 3 and 4. When finished, each Desktop had its own BMP image assigned. I then exited Dexpot and restarted it, and check the 'cube' by selecting each of the four faces in Dexpot's switchers, and each background was displaying properly!

A few additional comments that may be a help to others: I don't know if it was critical, but I selected "Run as administrator" in the Dexpot "Settings", as well as "Start with Windows". (There appears to be a bug in Dexpot, in that "Start with Windows" used to put an entry in the HKCU section of the Registry, but no longer does so; to make it autostart, I copied the Dexpot shortcut into the Startup [Common, i.e., for all users] Folder.) Additionally, I found each instance of the Dexpot shortcut, and set it's "Properties" - "Advanced..." setting to "Run as administrator".

Finally, I should note that the BMP files I created (using ACDSee32.exe's "Save as..." feature) are much larger than the JPG file I used as the source for each BMP file. On one PC, I had been using BMP files for 3 of the images, and initially, left them alone, but that was still problematic. I noted that each of those BMP files was quite a bit smaller than I would have expected, so perhaps they were JPG files "in disguise", i.e., with an incorrect JPG extension. I re-saved each of those files to a slightly different named BMP file using ACDSee32.exe, and noted that the file size increased considerably. Selecting those larger BMP files in Dexpot, instead of the smaller ones, solved the problem, they worked properly. It's true that my 'workaround' solution to the problem consumes additional disk space for the larger BMP files, but to me, I can live with it, provided the backgrounds change properly when I switch Desktops!

I hope that this explanation helps others who want to continue to use Dexpot, a wonderful program!

aboutblank
February 7, 2020

Return to “Support”

Who is online

Users browsing this forum: No registered users and 0 guests